Jump to content

Is anyone else lagging like crazy as of late?


Recommended Posts

I've noticed this getting worse over the course of the last few patches. DD is eating up 50% of my CPU, in addition to actual latency. It has reached the point where hosting any MF is impossible. Can anyone verify?

Share this post


Link to post
Share on other sites
I was getting some crazy lag spikes yesterday, but I think it might have been the host's connection (b/c it was on ramparts and endless spires which I never had probs with before, but Shipwreck Monster Fest seems to work fine for others when I host it. What are your system specs? I'm using i2500k, gtx 560 and 8 gigs of ram.

Share this post


Link to post
Share on other sites
I was getting some crazy lag spikes yesterday, but I think it might have been the host's connection. But Shipwreck Monster Fest seems to work fine for others when I host it. What are your system specs? I'm using i2500k, gtx 560 and 8 gigs of ram.
Not as impressive, but I have never had performance issues until recently; 2.8ghz dual core, 4gb ddr2-800 in dual channel mode, Geforce something with 1gb 256-bit gddr3, 7200rpm sata, at 1600x900.

Share this post


Link to post
Share on other sites
the ram and video card sound like there ok, but maybe the cpu just needs to be stronger for all the AI it has to generate when you host monster fests. does it lag when you run it solo?

Share this post


Link to post
Share on other sites
Not as impressive, but I have never had performance issues until recently; 2.8ghz dual core, 4gb ddr2-800 in dual channel mode, Geforce something with 1gb 256-bit gddr3, 7200rpm sata, at 1600x900.


I'd prescribe enzite for performance issues... :-)

Share this post


Link to post
Share on other sites
Seems the same for me. Yesterday I was hosting a survival on magus and at wave 11/12 the game just disconnected me and this has happened a handful of times in the past 3/4 days. I don't know if it has something to do with my internet connection though, I usually have a very stable connection though.

Share this post


Link to post
Share on other sites
I can verify this. Even putting graphic settings to low doesn't help at all. I get 10 - 15 fps on shipwreck and a little bit higher (like 1-3 fps more) on other MF maps. The small maps is not a problem, but the big maps is. I wish they have an option to remove some of the particles or any other options like different gfx for the auras (lesser particles).

Share this post


Link to post
Share on other sites
Uber Monster Fest? Uber Lag Fest. Despite all settings set to the lowest possible, I think my laptop dies a little every time...

Share this post


Link to post
Share on other sites
GTX 570 with 2500k@1080p

Considerable noise from my gpu fans recently. I play splitscreen so I expect a certain level of performance drain but it was only since shards prt3 that I noticed my system really starting to strain. The lag was always there to an extent, fps drops to sub 30, overall laggyness. But only recently did I have so much issues with regards to gpu temp.

For comparison, Im currently playing Arkham city and before that I was playing Witcher 2 and while both did have peaks in certain moments, neither of them hit anywhere near the temps(60+) that DD is doing so consistently. OMF turns my room into a mini sauna now :(

Share this post


Link to post
Share on other sites
Auras. If I boost them with a monk pet, and then click repair, the fans on my graphics spin up until I look away from them.

They need to reduce the effects as they scale up. Same with mage towers.
I'll be honest. I like playing a game that's like living in a rainbow, but not when it ruins FPS.
So, have it like monsters, where there's variation. Some monsters are fat/thin/big/small.
Do the same. Considerable reduce particles on 2/3 of them, randomly. It would make a vast improvement to framerate.

Also, as mention, change the density of effects in auras as they scale up. They're cool, but they're laggy.

Finally, network issues with practically all the monsters on the map taking damage from large auras causes hellish lag with 3 or more players.

Share this post


Link to post
Share on other sites
The inferno traps on top of apprentice towers drive my computer crazy. The lag I receive has gradually increased as they began adding in new content.

Share this post


Link to post
Share on other sites
Definetely laggy lately, but the last patch seems to have improved it slightly (or I could just be dropping into "good" games)

I think zingfarm is right to point at auras, as it only started after they got returned to a usable level (or soon after)

Share this post


Link to post
Share on other sites
Interesting point about Auras. I hadn't considered, but it makes sense. I never used to lag in OMF, and now it's so bad that I can't shoot straight enough to hit Sharken before they wreck my stuff :(

Share this post


Link to post
Share on other sites
I have had this issue in the past and I think it had something to do with my video drivers. When you're playing, and the game begins to lag, open task manager and check the size of your ddefenders.exe. I can remember the executable being over 1GB and the game would be unplayable.

My Rig: i7 | 16GB DDR3 | GTX 570

The problem went away after a few driver and game updates.

Share this post


Link to post
Share on other sites
I already suggested a "tone down audio/visuals" option with no response.
Some of the maps are unplayable atm.
Probably will never be addressed, instead we will get DD2 hopefully with some improved performance ;)

Share this post


Link to post
Share on other sites
I already suggested a "tone down audio/visuals" option with no response.
Some of the maps are unplayable atm.
Probably will never be addressed, instead we will get DD2 hopefully with some improved performance ;)


I'm guessing it has something to do with the game's garbage collection.

Share this post


Link to post
Share on other sites
Performance of Dungeon Defenders has become horrid for me lately. In Aquanos survivals it can drop below 10 fps very often. Add in multiple chars (split screen) and its a slideshow. I use the lowest effects in the dungeon defenders settings, with no post processing.

System Specs:
Windows 7 Pro 64-bit
AMD Phenom II 1050t (6 core)
4 GB dual channel RAM
GeForce 460 GTX (768mb ver)

I run at 1900x1200 full screen. Have tried both stock CPU speeds, and overclocked to 3300ghz. Improvement overclocked, but its still awful.

I used to get fairly decent framerates right up until Shards II (morrago).

I have the latest video drivers installed, and drivers for my operating system. I have checked all my hardware (even if my drives are in a non DMA mode), made sure my swap file is on a seperate HDD. Everything is defragged. I run a fairly bare bones system, like getting rid of non essential resident programs (adobe updater and rubbish like that). In other games such as Starcraft 2, Mass Effect 3 etc, I get smooth effortless framerates over 60fps at the same resolution, with all effects on.

My feel is that the particle effects in particular need to be optional. I don't feel many of them are optimized. I would prefer a more dour looking, but smoother game.

Share this post


Link to post
Share on other sites
  • 4 months later...
ive been getting a lot of lag to all the time like I'm playing with someone online and then it goes all lagy and I can hardly play! and it lags a lot on local to I don't know what the problem is can anyone help? D:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...