Jump to content

Problem with button assignment on a gamepad PC version


Recommended Posts

Hello!

I would like some help with this. I have a ps3 wired controller plugged into my pc and using a software to emulate a 360 controller I'm able to use in various steam games.  If I play other games everythings goes all right. But, when I use it on DD 1 it starts glitching. First of all the A and B button are changed. Also the X and Y are the other way around. The rb with rt and the lb with lt.

I've tried to change them from the configuration menu before launching the game but nothing happens. It's like that menu didn't work at all. But, If I go to the in game settings I see that the change is made on the controller settings. Is there a way to fix it? 

Share this post


Link to post
Share on other sites

Sorry, i don't know exactly what might be the best way to fix your problem, but perhaps editting the line commands in the txts at \Steam\steamapps\common\Dungeon Defenders\UDKGame\Config might help you, that's how i improved my emulator. Check UDKInput mainly, but im not quite sure if that's the only one related to key configs. Play around there and, if anything goes wrong, just "verity integrity" to recover the archives back to normal.

Share this post


Link to post
Share on other sites
  • 1 month later...

This may work out for you:-

Plug In your controller.

Go to Control Panel\Hardware and Sound\Devices and Printers

If your device is listed then right click on the device icon.

Select Game Controller Settings/Properties/Settings/Calibrate

Follow on screen Instructions.

Or click reset to default button at Game Controller Settings/Properties/Settings.

Share this post


Link to post
Share on other sites
14 hours ago, roundcube1 said:

This may work out for you:-

Plug In your controller.

Go to Control Panel\Hardware and Sound\Devices and Printers

If your device is listed then right click on the device icon.

Select Game Controller Settings/Properties/Settings/Calibrate

Follow on screen Instructions.

Or click reset to default button at Game Controller Settings/Properties/Settings.

 

It worked for me. Thanks. 

Share this post


Link to post
Share on other sites
  • 6 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...