Jump to content

3 equipped weapons bug (ev)


Recommended Posts

Heyo community!

Lately I 'found' (more like it happend to me) a bug with 3 weapons equipped. I was in some laggy lobby (akaiti jungle) and my weapon disappeared. I was on DPS ev with sceptre and clava and my clava disappeared. I haven't noticed that until boss. There was some bugs with shoothing but i was like 'oh maybe I unequipped that before'. In tavern i equipped another clava and go back to playing. After some farming and bugs with swapping weapons (toolbar was showing that I have sceptre enquipped, was shooting clava etc.) I decided to equip them again. 

Then something strange happend I unequipped my 1 clava and still got another clava equipped. I'm sure that I played some maps with 3 weapons equipped cause my ab2 stat was perfectly on 4000 and after unequipping one of them I was missing exactly amount from unequipped clava. 

Strange situation but sure that happend to me. No idea if soemthing similiar happend to someone else before.

Sorry for English and mistakes (not native), if something is not understandable go ahead and ask.

Share this post


Link to post
Share on other sites

That's a know bug that's getting fixed next patch. It usually happens when you swap weapons on laggy hosts

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...