Jump to content
Sign in to follow this  
Faysumi

Anyone else have this connection issue?

Recommended Posts



I figured it was a better idea to show it. Basically, every single time I startup the game/start a match/end a match (including quitting matches), I get time outs and errors that take a minute or more to resolve before I can move on. Effectively I can't play with other people as I'm stuck in place waiting for the game to tell me it's failed to do anything, then suddenly it magically finds me an opening like there was never a problem.

Also, this neuters any chance I have of ever getting repeated win bonuses since it just kicks me back to the town at the end of a match (even if I originally select to go to the Tavern).

All of this is taking in mind I have no problems running any other game, both spec-wise and connection-wise so something's definitely going wrong with this game specifically. I mean I'm not even mentioning the host of other issues I'm having at this point since this is the most important one at present.


Share this post


Link to post
Share on other sites

You'd need to look at your log.

Are you using any sort of VPN software on your machine?

What is running at startup with your PC

Share this post


Link to post
Share on other sites


@Lawlta quote:

What's your location and internet speed?

It's not about internet speed. I tried with my home connection of 300Mb/s (upload and download), and a friend's house (50Mb/s), and the problem persists. I have the same problem as Faysumi.

Hell, even on the main menu, when trying to leave a game or pressing continue/to taven buttons.

Share this post


Link to post
Share on other sites

I have a problem with going to another map with a friend. Most of the time it gives errors, but if I let it go long enough, it will eventually take me to a map with my friend. But, it takes a long time. It was not this bad before the chaos updates. I have a good connection and a good gaming computer. That is not the problem. I play other games much more graphically intensive then this and have no problem loading to a new map or level. I have partnered with people who have good computers and connections and gotten this problem. However it is not always bad. It's very inconsistent, like the server has problems a lot. Maybe part of the problem could be that the game code is bloated and needs to be stream lined, or the server code, or both!? 

Share this post


Link to post
Share on other sites


@Lawlta quote:

What's your location and internet speed?

England, and most recent check gives me: 19ms, 6.68dl and 1.91ul.

Pretty sure my download speed used to be better but it still runs everything perfectly fine.

@Nefhith quote:
@Lawlta quote:

What's your location and internet speed?

It's not about internet speed. I tried with my home connection of 300Mb/s (upload and download), and a friend's house (50Mb/s), and the problem persists. I have the same problem as Faysumi.

Hell, even on the main menu, when trying to leave a game or pressing continue/to taven buttons.

Same thing with the latter part there, I just cut to the chase with the main parts in the video. Joining the Tavern on the main menu is more likely to get me in quicker, but also, with the Chaos Trials, if I get a map I don't want, say for example because I have Daily Missions to do, it often won't let me leave straight away, wasting even more time. I actually spent 20 minutes trying to get the one map I needed out of 4 the other day and eventually got bored and gave up. Granted that's going into another subject.

Share this post


Link to post
Share on other sites

One thing is that in the top right, that carrot (the downward triangle), if you click that it should give a description of what's going on.  If you could do that, record it, and link it here, we might be able to tackle this and fix potentially other problems.  All you've done so far on this is greatly appreciated! :)

Share this post


Link to post
Share on other sites


@Lawlta quote:

One thing is that in the top right, that carrot (the downward triangle), if you click that it should give a description of what's going on.  If you could do that, record it, and link it here, we might be able to tackle this and fix potentially other problems.  All you've done so far on this is greatly appreciated! :)

It doesn't. I even sent pics and videos of it on the bugtracker site and got nothing.

Share this post


Link to post
Share on other sites


@Lawlta quote:

One thing is that in the top right, that carrot (the downward triangle), if you click that it should give a description of what's going on.  If you could do that, record it, and link it here, we might be able to tackle this and fix potentially other problems.  All you've done so far on this is greatly appreciated! :)

http://imgur.com/a/tcDhc

It doesn't show anything at all. Just keeps timing out all the time.

Here's a pastebin of the log: https://pastebin.com/zdqzwRDA

Edit: Another log with everything that happens between when you finish a map and it sends me back to the town: https://pastebin.com/rnxJr7Ci

Share this post


Link to post
Share on other sites

[[88490,users]]

Turn on logging as there isn't much in your log I can see.

Once you have a debug log suppress the logging again.

Share this post


Link to post
Share on other sites

The dev guys should look at those logs, it looks a bit weird to me, and the steps are different to mine, which works.

The process should be exactly the same irrespective of who clicks the buttons.

A theory I have, as a few people are having this issue, is that Trendy have changed the matchmaking in some way and maybe your patching has not gone through 100%.

As you have a nice big pipe (download I am meaning) could you delete the local files, delete the Dungeon Defenders 2 directory, clear your Steam download cache and reinstall the game afresh and see if your connection issues remain.

Share this post


Link to post
Share on other sites

hey guys. I also have this problem, I have a solution but its not a fix to the problem. I think it has to do with your internet. I normally use a wifi connection when i have this problem. But one day i connected my phone to my computer through usb and activated usb tethering (my phone is connected to the same wifi) everything started loading faster. I didnt realize that it was because of the usb tethering that it worked well until i disconnected it. 

So if you are having this problem, and you have an android phone, try plugging your phone to your computer and connect to the internet via usb tethering. This should help till they solve the problem at least its working for me.

Share this post


Link to post
Share on other sites


@Fozzie quote:

The dev guys should look at those logs, it looks a bit weird to me, and the steps are different to mine, which works.

The process should be exactly the same irrespective of who clicks the buttons.

A theory I have, as a few people are having this issue, is that Trendy have changed the matchmaking in some way and maybe your patching has not gone through 100%.

As you have a nice big pipe (download I am meaning) could you delete the local files, delete the Dungeon Defenders 2 directory, clear your Steam download cache and reinstall the game afresh and see if your connection issues remain.

I did it only because you said I have a big pipe ( ͡° ͜ʖ ͡°)

It kinnnda worked.... I think? The best improvement I've noticed is that I can join started games with no problem. Creating my own or end-match leaving is still a pain.



@Scorpion449 quote:

hey guys. I also have this problem, I have a solution but its not a fix to the problem. I think it has to do with your internet. I normally use a wifi connection when i have this problem. But one day i connected my phone to my computer through usb and activated usb tethering (my phone is connected to the same wifi) everything started loading faster. I didnt realize that it was because of the usb tethering that it worked well until i disconnected it. 

So if you are having this problem, and you have an android phone, try plugging your phone to your computer and connect to the internet via usb tethering. This should help till they solve the problem at least its working for me.

Worth a try. If it sounds stupid but it works, then it's not stupid!

Share this post


Link to post
Share on other sites

It does not sound stupid to me. Wifi interference is quite common since wifi is so widespread. Substituting a wired coneection for your wifi connection can solve a lot of connection issues.

I was having random disconnects of my wifi devices and finally figured out Windows would still turn on its wifi even though I turned it off and wasn't using it. Removing the wifi card from my Windows machine has made the random disconnects of my reading device go away.

Share this post


Link to post
Share on other sites

Yep, except I already tried wired, wi-fi, with a dedicated network card and 2 different computers. Same results.

Share this post


Link to post
Share on other sites


@Nefhith quote:


@Lawlta quote:

One thing is that in the top right, that carrot (the downward triangle), if you click that it should give a description of what's going on.  If you could do that, record it, and link it here, we might be able to tackle this and fix potentially other problems.  All you've done so far on this is greatly appreciated! :)

http://imgur.com/a/tcDhc

It doesn't show anything at all. Just keeps timing out all the time.

Here's a pastebin of the log: https://pastebin.com/zdqzwRDA

Edit: Another log with everything that happens between when you finish a map and it sends me back to the town: https://pastebin.com/rnxJr7Ci

How long was the load time from map finish to actually getting into town?

Share this post


Link to post
Share on other sites

When it DOES load, it doesn't take more than a few seconds. When I get stuck, it takes anything between 30 seconds to one minute.

Share this post


Link to post
Share on other sites

Well, damn. I don't really remember. If it's really important, I can do it again and time it.

By the way, since the last patch, there's been a small pain in the butt of a bug related with this:

QGawdbW.jpg

Sometimes you can't even close this window, forcing you to close and open the game, and hope it doesn't happen again, which, in my case (and whoever has these timing out problems) is quite a problem.

Share this post


Link to post
Share on other sites

For an accurate report, the log would have to cover a time when you ran into this issue.  I believe it was during a time when the game is running fine, the log will just show it running fine, and it won't show us any hang ups or errors that may be happening to cause the longer load times.  Any info is greatly appreciated!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...