Jump to content
Sign in to follow this  
Rebitaay

Need help with a strange performance issue

Recommended Posts

Hey all,

Just recently got into DD2 with a few friends and it's a great game so far, but I've got this issue where after a random amount of time (can be 10 minutes or 2 hours) the FPS goes from around 80-100 to about 40-50, it horribly stutters as if skipping every other frame (on an SSD), the sound can get crackly, and even my keyboard's lighting lags and skips.

When this happens, it seems like my entire PC (or at least most programs running) are lagging or "skipping" the same way that the game is. My CPU, GPU, SSD, and RAM usages remain normal, not spiking or anything. The only way to fix the issue (as far as I know) is to restart the game, and the issue occurs on all graphical settings, high or low.


I've searched around quite a bit and can't find much about this issue, so I'm hoping someone here will know how to fix this, or will at least be able to point me in the right direction.

Thanks in advanced!


CPU: i7-4790k 4.5ghz

GPU: GTX 960 4GB SSC

RAM: 16GB DDR3 1600mhz

SSD: 850 EVO M.2 250GB


I haven't actually checked the minimum specs, but I doubt it's a hardware issue seeing as how my friend with an i7-7700k, GTX 1060, and an (unkown) SSD has gotten the issue before.

Share this post


Link to post
Share on other sites

Hey Rebitaay, I was talking with you on reddit.  I've got this listed as an issue for us to look into, as it is a similar issue that a handful of other players have ran into.

Share this post


Link to post
Share on other sites


@Lawlta quote:

Hey Rebitaay, I was talking with you on reddit.  I've got this listed as an issue for us to look into, as it is a similar issue that a handful of other players have ran into.

Good to hear! Hope it gets fixed soon. Best of luck to the dev  team.

Share this post


Link to post
Share on other sites

I don't know if this helps, but in a different game, this same thing randomly happens to me if I alt-tab and come back into the game (studders for about 10-15 seconds every 5-10 mins).  I have to close out and restart the game and it goes back to normal. 

Share this post


Link to post
Share on other sites

Having the same issues aswell and Shift Tabing to bring overlay up takes a solid 3-5 secs and same with closing it.

CPU: AMD Ryzen 7 1700x
GPU: NVidia Gtx 980

RAM: 32GB DDR3

SSD: Idk its some stock one that came with my computer. its a 250gb

GFX Setting:High

Res: 1680x1050

Share this post


Link to post
Share on other sites

I used to have the same issue in DD survival games.

Back then i noticed that this starts when the game uses more than a certain amount of memory.

After that it gets progressively worse the more memory the game uses.  

I'm curious if this is the case here also.

Share this post


Link to post
Share on other sites

Here a video example of the issue. The video is in 1080p 60 FPS, so the "skipping" should be clearly visible. The game itself ran in 30-40 FPS during recording.


Share this post


Link to post
Share on other sites

Fantastic, thanks for the video submission for this issue, and that definitely should not be the case.  I've got this tracked and we'll be looking into.

The next time you have this happen, could you look at what your resource usage in task manager looks like to see if it's exceedingly high (memory/RAM usage, but CPU would be nice to see as well)?

Share this post


Link to post
Share on other sites


@Lawlta quote:

The next time you have this happen, could you look at what your resource usage in task manager looks like to see if it's exceedingly high (memory/RAM usage, but CPU would be nice to see as well)?

Yes, I'll find a way to record my usages during the issues next time, though they all seemed normal during the video. (I was looking at them on my second screen.)

Share this post


Link to post
Share on other sites


@Rebitaay quote:

Yes, I'll find a way to record my usages during the issues next time, though they all seemed normal during the video. (I was looking at them on my second screen.)

Oh just a note of what it is, maybe a screenshot, if they are high, would be a great help on its own if you're able to swing it.  Thanks for all your feedback so far!

Share this post


Link to post
Share on other sites

Lawlta Oh, I can do much better than that!

Here are two videos with stats in the lower left corner. One is before the bug happens, and the other is during the bug. One thing I noticed is that the GPU usage is much lower during the bug, perhaps that could be the cause? Also, it may be worth mentioning that this can happen by just AFKing in the Tavern. There doesn't seem to be anything specific that triggers the bug, the FPS just slowly drops over time. Anyways, hope this helps!


Normal:



Bugged:

Share this post


Link to post
Share on other sites

You are on fire with this feedback!  I'm assuming the first video is around the beginning of you starting the game up, how far in is the second video?

Share this post


Link to post
Share on other sites


@Lawlta quote:

You are on fire with this feedback!  I'm assuming the first video is around the beginning of you starting the game up, how far in is the second video?

The second video showing the bug was after about an hour or so of gameplay. It usually starts happening around there, sometimes sooner.

Share this post


Link to post
Share on other sites

So, we're researching this, and was wanting to know what you were doing between the two videos.  How many maps, changing settings, inventory usage, any kind of rough outline as to what's happening to make this easier to reproduce.

Share this post


Link to post
Share on other sites

Pretty much just normal gameplay, about two maps in. No settings changes, just equipping near gear. But I can just sit in the tavern and it starts happening, almost like a memory leak over time (though it doesn't actually appear to be a memory leak).

Share this post


Link to post
Share on other sites

you inspired me...instead of shutting down and restarting the game, I played until it crashed on it's own...no joke, .2 FPS in game, lol.

Video incoming, It's 1 hour & 10 minutes long;  9 GB big, going take YouTube a while to process.  Took 4ish Choas Trial runs.  Here is  a screen shot a bit before it crashed...when you see the vid, note, it's NOT the recording software, that's how the game actually plays...


sYVDmGp.jpg


Well I'm off to bed, You tube is telling me the video will be here when it's done:

https://youtu.be/iEoOQLEEpA0



https://www.youtube.com/watch?v=iEoOQLEEpA0&feature=youtu.be


Here is my original thread with some details: https://dungeondefenders.com/2/topic/146908/

Share this post


Link to post
Share on other sites


@Lawlta quote:

KamelJabber the video isn't loading/playing.  I think I found your youtube channel and it wasn't showing there, did it upload completely or possibly set to private?

Oops, thanks!  you're right it was set to private, I have published it and made it public, sorry sorry.

TY

Share this post


Link to post
Share on other sites

Oh wow, these almost seem like two separate issues.  [[20285,users]] your frames completely freeze, and then are smooth for another second or two, then freeze, rinse repeat. [[29740,users]] seems to have persistent frame reduction, with some choppiness on top of that.

Either way, these are fantastic examples of feedback.  I'm going to discuss this with the team.  If you guys have anything else (you've been such a tremendous help already!) then feel free to let me know, as it helps narrow things down.

Share this post


Link to post
Share on other sites

I am also having the same problem My Pc spec should eat this game. It does appear to happen after about an hour of playing.

Intel i7-7700k 4.2GHz

16Gb DDR4 Ram

ASUS 1080 GTX

Intel SSD (240gb)

Realtek HD Sound (on-board)

Restarting the game helps, but the play time before it happens again is much shorter. I have found even after I exit the game it takes 30sec or so for me Pc to run normally (Mouse is laggey and keyboard is laggy) .

Like the other poster said... It like a Memory leak. But when I check the usage while having this problem It tell me I have about 8gb free, Cpu is about 20% used.  My FPS is about 5 when having this problem, When its fine Its at 60fps (Vsync).

Share this post


Link to post
Share on other sites


@apinkbunny quote:

I am also having the same problem My Pc spec should eat this game. It does appear to happen after about an hour of playing.

Intel i7-7700k 4.2GHz

16Gb DDR4 Ram

ASUS 1080 GTX

Intel SSD (240gb)

Realtek HD Sound (on-board)

Restarting the game helps, but the play time before it happens again is much shorter. I have found even after I exit the game it takes 30sec or so for me Pc to run normally (Mouse is laggey and keyboard is laggy) .

Like the other poster said... It like a Memory leak. But when I check the usage while having this problem It tell me I have about 8gb free, Cpu is about 20% used.  My FPS is about 5 when having this problem, When its fine Its at 60fps (Vsync).

Interesting.  What do your log files look like for the game? (C:\Steam\Steamapps\common\Dungeon Defenders 2\DunDef2\UDKGame\Logs)  Want to know what the sizes look like in particular.

Share this post


Link to post
Share on other sites

the smallest one is 16kb and the biggest is 174kb and there a 19 logs. is that what you want to know?? 

If you would like me to upload the log i can, just tell me where to upload it.

Share this post


Link to post
Share on other sites

Nope, that answers it for me.  This issue is something that seems to affect a small group of users, which makes it harder to figure out, as we aren't able to reliably reproduce it on our end.  Have you tried reinstalling or verifying your steam files?

Share this post


Link to post
Share on other sites

Just out of curiosity, do you guys with the issue have an MSI motherboard? (might help to know the chipset too if you know it)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...