Jump to content

Really bad stuttering when playing on my new laptop


Recommended Posts

Basically stutters when i move on a character, fps etc all seem fine when standing still but the moment i start moving it just stutters none stop. No idea how to fix it, i did find some older threads saying change compatibility modes but that didn't seem to fix it, i've also tried running everything at low settings.


Laptop specs are

i7-7700HQ cpu

8GB ram

GTX 1050

Windows 10 64 bit

Share this post


Link to post
Share on other sites

Is the on die GFX being used? It has one yes?

Try checking the BIOS and disabling the GFX on the chip.

Share this post


Link to post
Share on other sites


@Fozzie quote:

Is the on die GFX being used? It has one yes?

Try checking the BIOS and disabling the GFX on the chip.

I hadn't even considered that - I checked and 2 display adapters are showing up


Intel HD 630

GTX 1050


I went into the bios but was unable to locate any option to turn off the onboard (which was odd), I tried to disable it via Device Manager, it wouldn't default the use to the GTX 1050 then however. At a bit of a loss now.

Share this post


Link to post
Share on other sites

apparently newer laptops use both onboard and a discrete gpu at the same time, they switch to the more powerful gpu when you start an application that demands more power and goes back to using onboard when not running such an app to save power.


At a loss then still :( the stuttering makes it virtually unplayable.

Share this post


Link to post
Share on other sites
  • 1 year later...
  • 2 weeks later...
Guest
This topic is now closed to further replies.
×
×
  • Create New...