Jump to content

My game won't launch once again. Please help


Recommended Posts

I have had this game for a while and have had to fix issues with it multiple times, unfortunately this is another time. When I try to launch the game it goes to the launcher. When I hit play in the launcher, the launcher disappears, the game doesn't load, and my steam profile goes from "Playing Dungeon Defenders 2" to just "Online" after a few seconds. I have tried verifying my game cache multiple times, re downloading the game multiple times. I have tried also tried all of the fixes that I have found on the forums and on the support site such as the no launcher fix, the winsock reset fix, and the deleting the UDK's. I have also tried uninstalling my antivirus software. I have also checked all of my drivers. The multiple times the game has been broken I have been able to fix it without a single word from any developer. The game was working just a month ago, I don't know what has changed, but i'm getting really tired of having to fix this game every time i want to play it. Can anyone please help me?

Share this post


Link to post
Share on other sites

I am also having same issue. Tried everything in my "IT" book. Editing processor utilization to only utilize Hardware/Software processing power. Compatibility Mode w/Admin Rights. Editing config files to run at different resolutions whilst adjusting different rendering presets. Firewall settings, restart PC, latest Nvidia and Intel Drivers. Win 10 64-bit. Steam launched game. I can't figure this out on top of above Troubleshooting steps.

Share this post


Link to post
Share on other sites

Any VPN software?

What starts with your OS?

Which OS is it?

Your firewall and router allow the usual ports and protocols?

Share this post


Link to post
Share on other sites

So I am not using VPN software, the launcher can load everything needed such as news feed and all. Never had this issue before until I wanted to play again. This is Windows 10 and I even allowed PC within DMZ as a test and still same issue. I wouldn't think the game not properly launching would be a layer 1-4 issue. I just performed a clean install and it is not working either.

Share this post


Link to post
Share on other sites

No VPN software. Not sure what you're asking with the second question. It's windows 10 home 64 bit and my firewall allows dd2 and even tried it with disabling the firwall. The router does allow all the usual ports. 

Share this post


Link to post
Share on other sites

I'm assuming the answer is 'yes' but I didn't see it in the list of things you've tried.. Did you guys try restarting the computer?

Share this post


Link to post
Share on other sites

Don't understand what it means but sure!

(22:44:58:223)Log: =============================(22:44:58:223)Log:

 CHECK YOUR GC PRE-ALLOCATIONS(22:44:58:223)Log: =============================

(22:44:58:224)Log: Initializing Engine...(22:44:58:275)Warning: Warning, Failed to load 'Texture2D DunDefNullTexture.NullTexture': Failed to find object 'Texture2D DunDefNullTexture.NullTexture'(22:44:58:276)Warning: Warning, Failed to load 'Class None.': Failed to find object 'Class None.'(22:44:58:276)Warning: Warning, Failed to find object 'Class None.'(22:44:58:372)Log: Object size..............: 64


Looks like missing or corrupted objects to me. Even with fresh install it didn't repair anything.

Share this post


Link to post
Share on other sites

Raymundo, try this: \Steam\steamapps\common\Dungeon Defenders 2\DunDef2\UDKGame\Logs

Sort by ---> Most Recent

Share this post


Link to post
Share on other sites

Go to Dungeon Defender 2 and then search for "logs"


Share this post


Link to post
Share on other sites

I don't know man :o. At that point I would reinstall DunDef2 just to see if it makes a log folder. If you don't even have that then there is something deeper at hand in your case. Sounds like corruption.

Share this post


Link to post
Share on other sites

We will try to help eachother raymundomanofdoo I guess since no one else really knows what's going on and the Trendy guys are almost non-existent on these forums. Could you upload a screenshot within the \Steam\steamapps\common\Dungeon Defenders 2\DunDef2\UDKGame folder for me?

It appears that Trendy needs to push out an update to fix these bugs.

Share this post


Link to post
Share on other sites

When you uninstalled did you delete the dungeon defenders 2 directory and delete your Steam download cache?

I'd also check which visual c++ libraries it uses and uninstall those too

Then reboot your pic and then download it from scratch and install it ensuring it applies the visual c++ prerequisites during the install.

The account you login to the PC is a local admin and family sharing is off in Steam?

Share this post


Link to post
Share on other sites


@Fozzie quote:

When you uninstalled did you delete the dungeon defenders 2 directory and delete your Steam download cache?

I'd also check which visual c++ libraries it uses and uninstall those too

Then reboot your pic and then download it from scratch and install it ensuring it applies the visual c++ prerequisites during the install.

The account you login to the PC is a local admin and family sharing is off in Steam?

Hey help me out too lol, good tips for him though. My logs are on the first page. Thanks bro

Share this post


Link to post
Share on other sites

I deleted the directory and download cache before. Just tried it with uninstalling the c++ libraries and same result. This is the only account on the pc, it is an admin account of course, and family sharing is off in Steam. Thank you for the help even if it didn't yield any results. 

Share this post


Link to post
Share on other sites


@raymundomanofdoo quote:

I deleted the directory and download cache before. Just tried it with uninstalling the c++ libraries and same result. This is the only account on the pc, it is an admin account of course, and family sharing is off in Steam. Thank you for the help even if it didn't yield any results. 

Pretty basic question but have you tried running the DunDefGame.exe in compatibility settings along with admin rights request?

Share this post


Link to post
Share on other sites

I have tried running it as admin, in compatibility mode for windows xp, 7, and 8 with 8 being the one that the compatibility troubleshooter said i should run it in, none of them worked. 

Share this post


Link to post
Share on other sites

I found something new in my case. I ran my VPN and connected to a VPN in the United States and I played the game and it ran just fine. Then I closed it, disconnected my VPN and attempted to run the game and it did not run. I am going to analyze my log files right now to see the cause of that. Maybe placing my system in the router DMZ would allow me to access the game, I don't know. I think I am on to something though. Are you located in Europe as well?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...