Jump to content

Serious audio and frame stutter to crash


Recommended Posts

Hello. I recently started playing DD2 again after missing quite a few patches. The game always worked just fine for me until now. When I launch the game and start playing everything goes just fine. But after I've been in game playing for about 30 minutes or so I slowly start getting some light frame stuttering. If I stay in for another 30 minutes after this starts to happen I start getting some serious audio skipping (music, sound effects, and even audio from other sources like ventrilo and media players) and huge frame skips. Eventually the game just crashes and all other sources of audio go back to normal. I have tried reducing the graphical settings, using/not using vsync, verifying the game cache (steam), uninstalling reinstalling, even deleted everything pertaining to DD2 in appdata and residual files left in steam apps after the uninstall. I can't seem to pinpoint what is causing this.

(also its not an overheating problem I monitored temps while playing max gpu and cpu temps never exceeded 50c)

Also another little bit of an issue. If I leave the social "tavern" to enter the private tavern when I go to start a game no maps show up at the wartable. It just shows the game type/public/private/difficulty. No maps

PC specs:

Win 7 ultimate 64-bit

i5-2500

Nvidia GeForce GTX 980

16GB ram


Share this post


Link to post
Share on other sites

What's your CPU and GPU usage before, during, and after?

As for the missing maps at the war table, you have to wait for the server to catch up after entering/switching taverns. 


I don't think it's a memory leak, but it's possible. 

Share this post


Link to post
Share on other sites

cpu around 55% max gpu 25%~ max. and actually once the frame drops start to happen the gpu usage actually starts to go down to about 5-10% but I assume thats due to the fewer ammount of actual frames rendered

The issues seem to progressively get worse after each new wave starts.  Everything about this is tell-tale signs of some sort of memory leakage. Ive looked all over the forums and have only seen one other person with an issue similar to mine. Did some extensive google searches as well with no luck.


You are correct about the war table thing though those do seem to come back after a few moments.

Share this post


Link to post
Share on other sites


@psycho_savage@msn.com quote:

cpu around 55% max gpu 25%~ max. and actually once the frame drops start to happen the gpu usage actually starts to go down to about 5-10% but I assume thats due to the fewer ammount of actual frames rendered

The issues seem to progressively get worse after each new wave starts.  Everything about this is tell-tale signs of some sort of memory leakage. Ive looked all over the forums and have only seen one other person with an issue similar to mine. Did some extensive google searches as well with no luck.


You are correct about the war table thing though those do seem to come back after a few moments.

Onslaught I'm guessing? I've actually seen a few posts mentioning this issue as well. Unfortunately nothing I can do my end, and my best guess would be that it is indeed a memory leak and *fingers crossed* gets addressed very soon. 

Go into the game and submit a bug report. That would, in my opinion, currently be the best course of action!

Share this post


Link to post
Share on other sites

Probably a good idea. And no it is not just in onslaught. It happens in every game mode. I can only manage to make it all the way through one map before I have to close and reopen the game. If I start a second without restarting the game it will crash somewhere near the end of the second run.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...