Jump to content
Sign in to follow this  
Kamikaze_hfx

Extreme ui/inventory lag

Recommended Posts

I will start the game and play a map.

After finishing the map I come back to tavern to peruse my loot.

I do a lot of hero swapping and I will frequently switch between the inventory and stats tabs.

The whole game will hang up for at least a second or more when opening the inventory and switching between tabs.

It is smooth-ish when first starting the game, but it gets worse until it's unbearable and I have to restart the game.

I can get the game to run well enough in most situations (50-70 fps) but swapping heroes and inventory/forge tabs causes the game to lag horribly. 


 I can't be the only one...

I hope this issue gets addressed at some point. wyvern.png 

Share this post


Link to post
Share on other sites

yea, me and my friends experienced this as well. According to one of my friends, he said it was an issue of memory build up (which I don't have a single clue about).

So far, the only known temporary solution are the following:
1. Selecting a new map (doesn't many whether its the same map as the previous or not). Or in other words, either click replay map or go to tavern and select a new map.
2. Restarting DD2.

Share this post


Link to post
Share on other sites

i have the same problem

there's like an extreme lag when i press I to open inventory and MORE extreme lag when i click heroes tab to change heroes

the only way i found to fix is basically restarting dd2

i havent seen or heard any plans on fixing this on any of the devstream


Share this post


Link to post
Share on other sites

yes, I have the same issue but after a couple of hour of play, if you try to change deck from inventory the game can also crash due time out !!! I happened to me when I was already in wave 47 T_T Onslaught

Share this post


Link to post
Share on other sites


@DarkChuky quote:

yes, I have the same issue but after a couple of hour of play, if you try to change deck from inventory the game can also crash due time out !!! I happened to me when I was already in wave 47 T_T Onslaught

Exactly my concern. This issue affects onslaught the most as from time to time we'll need to access the inventory tab / hero tab. It wouldn't be fair if we have reached wave 50 and suddenly the game crashes because of this issue. Hope Trendy realizes this issue and have it fixed ASAP.

Share this post


Link to post
Share on other sites

We're looking into it. Can someone confirm if keeping your bags clear reduces the issue?

Share this post


Link to post
Share on other sites


@iamisom quote:

We're looking into it. Can someone confirm if keeping your bags clear reduces the issue?

I dont think the issue is whether or not the bag is full of items (not 100% sure on this), but one thing is definite, that is, the more frequent I open up my inventory (by pressing "i"), and switching tabs and heroes, the more freeze time there is (i.e. freeze time progressively increasing).

Thanks for response, hope you guys can figure it out. Have a great day!

Share this post


Link to post
Share on other sites


@iamisom quote:

We're looking into it. Can someone confirm if keeping your bags clear reduces the issue?

No that doesn't help.

you can clean up your inventory, close, try to enter again, it will lag and take a while to access it. Also when the inventory load, now go to your Deck (in the inventory, not the new UI) lag again, it load, change you char, go back to inventory, lag again.... now close the inventory... uff lag again...

in any of that lagging moment you can get disconnected, and the lag raises as more you play, you can reproduce this on an Onslaught, if you reach round 15, you already can see the lag. That means you have been playing for hours.... Had not review the Memory usage, sorry.


One more detail, normally I play in full randomized. Don't know if can happen in other modes, but sounds like memory issues so probably yes.

I'm using GeForce 970 4GB, AMD 8320 and 16GB ram, Win 10 Pro.

Share this post


Link to post
Share on other sites


@iamisom quote:

We think we've found the issue! Thanks everyone. :D

Oh my...this is great. This is actually the first time I voiced my issues via a forum and it might get fixed. Thanks for the response :D

Hopefully in the next patch it gets fixed. Thanks Trendy!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...