Jump to content

Recommended Posts

I tried to play the game again today after seeing that Trendy patched the matchmaking bug. However, now I can't even get into the social tavern. I press "Play" and then after ~2 minutes of searching for a session, the client gives up and leaves me on the landing screen.

Share this post


Link to post
Share on other sites

Hi @You know nothing, Jon Snow, 

First off, that's a pretty cool name. 

Secondly, we are glad that your issue was resolved. If it ever occurs again, please fill out a bug report form or contact our support desk at support[at]trendyent[dot]com. 

Share this post


Link to post
Share on other sites
  • 7 months later...
  • 1 year later...

Same here, i'm always having this problem. When I try to even join a server of my private tavern, it sometimes would give me a matchmaking error, something belong the lines of

"Server is taking too many requests that is under 5 seconds long, please try again later"

(^ that's all I remember for it)

Even when I'm done with a game of anything, campaign, nm1/2/3/4, incursions and more.

When I would click go to tavern, it would make me wait 2 minutes on a empty loading screen before giving me an error. I cannot fix it no matter what :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...