Jump to content

Way to change FOV or what? Getting to the point I can't play anymore...


Recommended Posts

I posted a request for some technical info in a recent thread (including this request about changing the FOV), but it's been a week now with no responses. Other issues aside, the one thing I really need to figure out is how we can change the field-of-view in DD2.

The default FOV is just way too narrow for some people like me; playing the game for more than 20 or 30 minutes starts to make my eyes hurt and gives me headache or dizzy feeling. I know that sounds dramatic as all hell, but I wouldn't have believed it myself unless I experienced it. I've already found out how to disable some of the graphics settings via the INI (like depth-of-field, motion blur, excessive bloom, etc.), but there's no default entry for FOV in any of the INI files.

There was a post on the Steam forums where someone suggested adding "FOV=X" at the bottom of the engine INI, although we don't really know if this is the correct parameter (and if it is, whether or not that's the correct INI file to place it in, and if it can just be thrown in there at the bottom, as opposed to under a specific heading). Obviously I've already tested it by trying it, but it doesn't seem to work (tried setting a FOV=95).

Please get back to us regarding this specific issue at least, guys... I can understand why the stuff I asked in the aforementioned post isn't a high priority for you guys right now, but this FOV issue is gonna actually cause people like me to stop playing until it's fixed. And seeing as I just bought the damn game over the holidays, I don't wanna stop playing yet.


Share this post


Link to post
Share on other sites

Come on, Trendy... Give us a heads-up, here. When you've got more than one third-party site that's claiming motion sickness and nausea with DD2, that should be a clear sign it's an issue that needs to be addressed:


https://steamcommunity.com/app/236110/discussions/0/624076851200051295/


http://sol-three.com/solving-motion-blur-fov-problems-in-dungeon-defenders-2/


And hey, I'm not even necessarily asking for your dev team to patch in a fix, at least not right away. But it would take a CM just a couple minutes to shoot an email off to the tech guys and find out how the FOV can be changed (either in-game via console commands, or by adding a value to one of the INI files). This doesn't have to be an "end-user-friendly" fix right now; I think a lot of us would be happy with the solution I mentioned here, at least for now...


Look at my Steam history on this game, for cryin' out loud... I'm a huge DD fan (700+ hours with the original), I own DDE and now I've owned DD2 since mid-December. You'd think a fan like that would have racked-up 50 to 100 hours by now, but as you can see, I've only been able to play the thing 15 hours in almost a month here, because my eyes and head can only stand about one match per gaming session.


Are you guys actually monitoring this board or what? You guys decided to throw this game into-the-wild and sell it early-access via Steam; there are some responsibilities that come with that decision, especially when we're talking about people who bought a game that's gonna be free, and have already spent a lot of cash on your properties since the original...

Share this post


Link to post
Share on other sites

Hi WaxPaper, 

First, please accept our sincere apologies for not replying to this post sooner, we did not mean to cause you any inconvenience or prolong any discomfort. 

I just talked to one of the programmers and right now there is not an option to change the FOV values, not even through the .INI files. We will bring the matter up in the future, as you are not the only person that has brought this matter to our attention. 

We have noticed that some players are experiencing nausea and headaches. One of the workaround fixes that has been discussed has been to turn off the post-processing option in the video tab. This has provided some relief for a number of players, and we are disseminating it as a workaround until we get a more concrete option from our programming team. 

Again, we want to apologize for the delay and inconvenience. If you have any questions, or are still experiencing problems, please let us know. Thank you for your patience with us!

Share this post


Link to post
Share on other sites
  • 6 months later...

Is this getting fixed yet? It needs to be a priority, it's sickening playing the game as-is, and changing the fov values in the ini doesn't change anything.

Consoles fps/tps: fov don't matter for most.

PC game fps/tps: Top priority - should be one of the first settings in the game.

Share this post


Link to post
Share on other sites


@Powered by Tears ® quote:

Is this getting fixed yet? It needs to be a priority, it's sickening playing the game as-is, and changing the fov values in the ini doesn't change anything.

Consoles fps/tps: fov don't matter for most.

PC game fps/tps: Top priority - should be one of the first settings in the game.

Hi there! I'd like to apologize for any inconvenience this may have caused you. 

This is in our Game team's to-do list, and they are currently exploring several different ways to tackle this problem. We appreciate your concern, and agree with you that it is a pressing issue, one of several related to display properties and player comfort.

Keep an eye out on the hotfixes and patch notes. That is where we post any and all fixes that go into the game. 

Thank you for the feedback and support!

Share this post


Link to post
Share on other sites

Not sure if related, but after every hotfix my DD2 zooms in, and by scrolling the mouse well it seems to fix the issue, providing some sort of fov. It's not a proper fov slider, but it might be enough to help currently. Hope it somehow helps.

Share this post


Link to post
Share on other sites
@TheCrimsonTea quote:

Not sure if related, but after every hotfix my DD2 zooms in, and by scrolling the mouse well it seems to fix the issue, providing some sort of fov. It's not a proper fov slider, but it might be enough to help currently. Hope it somehow helps.

Nah same thing, no fov change, mouse wheel hasn't and still doesn't do anything.

You sure you're not confusing when you make attacks? When you attack the fov increases slightly, but still sickeningly narrow overall. I want to play more, but with the current FOV it's impossible to enjoy it.

Share this post


Link to post
Share on other sites

What does your video settings look like? (In the options tab in DD2)

I'm pretty sensitive when it comes to motion sickness in modern games but with these settings in DD2 i'm not feeling much:

Fullscreen, 1920x1080

Custom graphics settings:

Texture quality: High

Antialiasing: 2

Anisotropic filtering: 2

Detail mesh draw distance: Medium

Vsync, Postprocessing and Dynamic shadows are all enabled.


And in-game i've always got the character zoomed out as much as possible.


I know aswell that the FOV can cause these effects but crispier textures and what not seems to have an impact aswell..

Have you tried sitting a bit further away from the screen aswell? 

Hope you can get it sorted! :-(


Share this post


Link to post
Share on other sites

Heya Chop, the FOV is a hard setting that typically ranges from 60 to 120, most people are comfortable with it in the 90 range but I prefer 110, and it's something only the developer can make adjustable. Sitting further back can work but it's unrealistic to do. Still I appreciate you making some suggestions, the devs just need to make this a priority.

I'm surprised it's been disabled and not been implemented yet, I don't know of any other Unreal Engine games that purposefully disable the FOV.

Share this post


Link to post
Share on other sites
  • 2 months later...

Just checking in here... Haven't played since June or so; has this issue been fixed so that the FOV is either adjustable in-game or with a config tweak via the .ini file yet?

Share this post


Link to post
Share on other sites


@WaxPaper quote:

Just checking in here... Haven't played since June or so; has this issue been fixed so that the FOV is either adjustable in-game or with a config tweak via the .ini file yet?

You can use the console command fov X (X being the value between 1 -170, and 0 for default)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...