Jump to content

Failed to Create Game


Recommended Posts

When I try to create a game (public or private) It comes up with the message "Failed to create game" I'm on windows 8, I don't have (or will ever have) hamachi. I've set the game launch options to -tcp, and I've tried verifying my game cache. None of that has changed anything. Except skipping the start screen and undoing my settings of course. Does anyone have any other ideas?

Share this post


Link to post
Share on other sites
When I try to create a game (public or private) It comes up with the message "Failed to create game" I'm on windows 8, I don't have (or will ever have) hamachi. I've set the game launch options to -tcp, and I've tried verifying my game cache. None of that has changed anything. Except skipping the start screen and undoing my settings of course. Does anyone have any other ideas?


I had that problem on Windows 8 but the -tcp option is what fixed it for me. Do you have a firewall in place that may be blocking it from creating a game? If you do, I would recommend disabling it momentarily just to check.

Share this post


Link to post
Share on other sites
I had that problem on Windows 8 but the -tcp option is what fixed it for me. Do you have a firewall in place that may be blocking it from creating a game? If you do, I would recommend disabling it momentarily just to check.


Oh I forgot to mention that I tried disabling my firewall already.

Share this post


Link to post
Share on other sites
Oh I forgot to mention that I tried disabling my firewall already.


Well I am not sure then since it seems to start fine and I assume you can join games properly. Normally that has been the -tcp option that was the issue. I think some have had issues with a firewall or router as well before but you have checked those too.

Have you tried Right clicking and selecting Run as Administrator? Not sure if that is required but worth a shot if not already tried.

Share this post


Link to post
Share on other sites
Well I am not sure then since it seems to start fine and I assume you can join games properly. Normally that has been the -tcp option that was the issue. I think some have had issues with a firewall or router as well before but you have checked those too.

Have you tried Right clicking and selecting Run as Administrator? Not sure if that is required but worth a shot if not already tried.


Yeah I've tried running as an administrator too... I hope this is fixable... I played DD for a long time on my old computer and I want to be able to come back to it...

Share this post


Link to post
Share on other sites
Yeah I've tried running as an administrator too... I hope this is fixable... I played DD for a long time on my old computer and I want to be able to come back to it...


It should be fixable as it works on my windows 8 computer.

Share this post


Link to post
Share on other sites
Do you have any non-alpha numeric characters in your name?

I had an issue in the past where I had "@" and "!" in my steamID and it refused to create games.

Share this post


Link to post
Share on other sites
Do you have any non-alpha numeric characters in your name?

I had an issue in the past where I had "@" and "!" in my steamID and it refused to create games.


Nope, I'm returning to the game. I played it for a long time back on my old computer so my username has nothing to do with the issue :/

Share this post


Link to post
Share on other sites
It´s doing the same to my game, I can´t start up my game anymore. after trying it with -tcp It simply doesn´t start a game and sends me the error instantly instead of waiting for a bit. Im playing on ranked. I can join other games though.
I use windows 8 as well.

Share this post


Link to post
Share on other sites
It´s doing the same to my game, I can´t start up my game anymore. after trying it with -tcp It simply doesn´t start a game and sends me the error instantly instead of waiting for a bit. Im playing on ranked. I can join other games though.
I use windows 8 as well.


Sounds like the exact same issue I'm having. When I put -tcp it does it instantly instead of stalling too.

Share this post


Link to post
Share on other sites
Sounds like the exact same issue I'm having. When I put -tcp it does it instantly instead of stalling too.



I'm having the EXACT same problem. I dont know what to do.

Share this post


Link to post
Share on other sites
Did anyone change anything on their system? New hardware? Install another game which may have updated some core libraries? This is pretty strange so many are having the problem.

Aside from verifying cache, you may want to reinstall support files for DD. I found this in a post somewhere so maybe it will help.

...\Steam\Steamapps\common\dungeon defenders\Binaries\redist\UE3Redist.exe

Reboot your computer and test the issue again.


Here is a thread with some more possible fixes.
http://forums.dungeondefenders2.com/showthread.php?96101-Dungeon-Defenders-won-t-start

Share this post


Link to post
Share on other sites
Aside from dll file DLs (which is extremely difficult to recommend, but can work), http://forums.dungeondefenders2.com/showthread.php?112322-Failed-To-Connect-To-Trendy-Net/page2 < last post.

"So, I ran into this problem as well, and the last time this happened I actually re-installed Windows to get Dungeon Defenders to work again. That being said, it happened again, and I wanted to get to the bottom of this, so I read through all of your suggestions, and I can say with some confidence that the 'only thing' that really worked for me was making sure that the check mark for 'Run-as Administrator' was selected under the compatability tab for the following executables:

C:\Program Files (x86)\Steam\SteamApps\common\Dungeon Defenders\Binaries\DunDefConfig.exe
C:\Program Files (x86)\Steam\SteamApps\common\Dungeon Defenders\Binaries\Win32\DunDefGame.exe
C:\Program Files (x86)\Steam\SteamApps\common\Dungeon Defenders\Binaries\Win32\DungeonDefenders.exe

Apparently, being an administrator on your own machine already may not be sufficient when trying to troubleshoot this issue.

Additionally, I also wanted to point out that this could have been firewall related as well, as only after the application was run as an admin did I get a UAC yes/no prompt, and my firewall did ask whether to run the application as 'unlimited/trusted'.

Thank you all for your input and helpful suggestions, it was nice being able to see what everyone else had tried, before giving up on this."

I don't normally run with Win 8 but I do recall having some issues with admin status not being true admin in Win 8.

Share this post


Link to post
Share on other sites
Aside from dll file DLs (which is extremely difficult to recommend, but can work), http://forums.dungeondefenders2.com/showthread.php?112322-Failed-To-Connect-To-Trendy-Net/page2 < last post.

"So, I ran into this problem as well, and the last time this happened I actually re-installed Windows to get Dungeon Defenders to work again. That being said, it happened again, and I wanted to get to the bottom of this, so I read through all of your suggestions, and I can say with some confidence that the 'only thing' that really worked for me was making sure that the check mark for 'Run-as Administrator' was selected under the compatability tab for the following executables:

C:\Program Files (x86)\Steam\SteamApps\common\Dungeon Defenders\Binaries\DunDefConfig.exe
C:\Program Files (x86)\Steam\SteamApps\common\Dungeon Defenders\Binaries\Win32\DunDefGame.exe
C:\Program Files (x86)\Steam\SteamApps\common\Dungeon Defenders\Binaries\Win32\DungeonDefenders.exe

Apparently, being an administrator on your own machine already may not be sufficient when trying to troubleshoot this issue.

Additionally, I also wanted to point out that this could have been firewall related as well, as only after the application was run as an admin did I get a UAC yes/no prompt, and my firewall did ask whether to run the application as 'unlimited/trusted'.

Thank you all for your input and helpful suggestions, it was nice being able to see what everyone else had tried, before giving up on this."

I don't normally run with Win 8 but I do recall having some issues with admin status not being true admin in Win 8.

I've seen that post and all of them are checked as admin. didn't change anything.

Share this post


Link to post
Share on other sites
I've seen that post and all of them are checked as admin. didn't change anything.


Have you been able to try anything from my previous post? I am curious as to what may be causing this now as so many seem to have it.

Does anyone use automatic updates on Windows 8? Maybe that changed something.

Share this post


Link to post
Share on other sites
Maybe a longshot but try and disable ICS (Internet connection Sharing) if it isn't already?

http://steamcommunity.com/app/8930/discussions/0/828939797196565447/

I'll check and see if it's disabled already when I get back home (Win 7), DDace as you're on Win 8 and you say it works fine for you can you check and see if ICS is enabled or disabled on yours?

MMC > services > Internet Connection Sharing.

Share this post


Link to post
Share on other sites
Maybe a longshot but try and disable ICS (Internet connection Sharing) if it isn't already?

http://steamcommunity.com/app/8930/discussions/0/828939797196565447/

I'll check and see if it's disabled already when I get back home (Win 7), DDace as you're on Win 8 and you say it works fine for you can you check and see if ICS is enabled or disabled on yours?

MMC > services > Internet Connection Sharing.


Mine's already off

Share this post


Link to post
Share on other sites
So this problem started happening to me about 2 months ago - I could join other games but not host my own (Windows 8.1) and it was working before on the same PC. No firewalls, admin settings, or software settings (-tcp included) worked until today and the ICS comment made me think to try it out: I disabled all other network adapters other than my primary and bam, I could host again. I'm guessing it's the VMware program I installed around the same time that added an adapter and the game was trying to communicate over it instead of the proper ethernet connection. If you can't join at all, maybe see if you have additional adapters in Network and Internet settings you can disable and test: Control Panel\Network and Internet\Network Connections > right click any adapter other than your primary, disable. Double-click or right click > enable if you turn off your main connection accidentally or want to turn one back on.

Hosting works with the Teamviewer VPN Adapter but didn't with VMware Network Adapter VMnet1 or VMware Network Adapter VMnet8. Bridging the connections just dropped all connectivity to the internet and I didn't want to learn how to get that to work badly enough to configure it. Disabling those two VMware adapaters works properly. Hope this helps!

Share this post


Link to post
Share on other sites
Those still having this problem
If using a router try resetting it by depressing the small button located on it probably in the back. Do the same with your modem.
Also check your Modem /router settings.
I could not access DDE past the title screen and it turned out the Comcast router/modem was blocking something .
No notice no visual indicator but it was blocking.

I had Comcast swap it out and bam in the game I was.
Check with your provider if you don't know how to access the router settings or if you own your equipment check the manual as well.

I know your talking about DD not DDE but the problem sounds very similar..

Share this post


Link to post
Share on other sites
@Synergy - That's good to know, I have VirtualBox installed currently but I don't have the eth adapter for it enabled. I should give it a shot and see if that interrupts hosting access.

@Torin - I see ICS is disabled already on yours as is mine, do you have a similiar setup to Syn - multiple eth adapters?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...