Jump to content
Sign in to follow this  
RhynoD

[bug] [graphics] Black screen, can't see hero, etc.

Recommended Posts

I had some trouble just getting the game to work, which I resolved by disconnecting my second monitor. It would get past the sponsor intros and then my computer would just...turn off. Not shut down, not crash. Just...off. But with my other monitor unplugged I can actually get into the game.

However, I can't see much of anything. All I get is a black screen with the option buttons. Instead of seeing the hero preview in the hero selection screen, I just get random strobing colors. In game, I see black with options buttons and nothing else. Cannot see the map, cannot see my hero, can't see anything other than the HUD.


Computer specs:

Share this post


Link to post
Share on other sites
Checked the file integrity, fixed some, and got back to the "computer turns off for no reason" problem. Tried it in windowed mode with the lowest graphics setting, BAM, it worked. Tried to fullscreen it and BAM, computer turned off for no reason.

Back to windowed mode, on various settings, and now, again, I get nothing but black screen with menu buttons.

Srsly, anyone know what's going on?

Share this post


Link to post
Share on other sites
Can't even get into the game in windowed mode. No idea what's going on, could really use some help or advice...

Share this post


Link to post
Share on other sites
Checked the file integrity, fixed some, and got back to the "computer turns off for no reason" problem. Tried it in windowed mode with the lowest graphics setting, BAM, it worked. Tried to fullscreen it and BAM, computer turned off for no reason.

Back to windowed mode, on various settings, and now, again, I get nothing but black screen with menu buttons.

Srsly, anyone know what's going on?



Please send your DxDiag file to [email]support@trendyent.com[/email]. This allows us to see what hardware you're running and some additional details about your computer that may assist us.

Start -> Run -> type dxdiag and hit enter
or
Start -> type dxdiag and hit enter

Then click save all information and it'll put it into a DxDiag.txt file.

It sounds like your computer is overheating. Does your computer turn off when you try to run other games or programs?

Share this post


Link to post
Share on other sites
Thanks! Running it now.

As a side note, apparently it had trouble accessing some information last time. I have no idea when that last time was? But I'm telling it not to skip that information.

I considered overheating as a problem. I have had it shut down when attempting to play League of Legends in the same way, so I am absolutely open to this having nothing to do with Dungeon Defenders and just a problem with my computer.

The reasons I do not believe this to be the case, though, is that it happens even if I crank the AC in the room up and point a room fan directly at my computer with the case open. My CPU core temperature stays below 50*C, generally. I've seen it spike to 61*, but even that shouldn't be too high. I do not, however, know what my GPU temperature does. I'm sure the fan needs dusting, but I don't think it could be overheating THAT badly. Moreover, my understanding is that Dungeon Defenders is not a particularly graphics-intensive game, and I'm able to run League on the highest graphical settings without a problem. I can run DD, but only in windowed mode and lowest graphics settings.

If I touch the full-screen button in the corner of the screen, my computer immediately shuts off. There is NO noticeable delay: fullscreen, computer off. A similar thing happens if I just try to load the game in fullscreen mode: get past the developer intros, get to the stylized arcane circle that indicates the game is loading, and the computer turns off. And the computer does not shut down, it just turns off, as if I unplugged it, and will not turn back on until I cut the power on the power supply and leave it off for several seconds. This happens even if I run nothing but Steam and DD with my second monitor unplugged and turned off. Once I get everything back on, I have to validate the game's local cache before it will work, and every it finds three files to reacquire.

If I load the game in windowed mode on anything but the lowest settings, I get menu buttons and an otherwise black screen.

I'm not computer savvy enough to know exactly how my GPU interacts with game files, whether or not it can corrupt the local files that way, or what an overheating misbehaving GPU looks like. I don't think it's a problem with my computer - or at least, a problem confined to my computer and not the game - but I'm open to the idea that my hardware is wonky.

Emailing the information now. There will be two: I ran the program again in 64 bit.

EDIT: Just crashed even in windowed mode on low...EDIT: Repeatedly. Can't get into the game today, apparently. It was working "just fine" yesterday (given the restraints it took to make it work, anyways).
EDIT: Running a GPU temputer windows widget. It's at 35*. Probably not a problem, there.


I have also considered the possibility that my power supply is failing and not providing as much power as it should be and my system is overloading it when the GPU kicks in to process the game. It's getting on in years. But again, there should be more than enough margin for error, so while it's a distinct possibility, I'm still not convinced that's the problem...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...